EB IT Support LTD - UK Power Failure – Incident details

All systems operational

UK Power Failure

Resolved
Major outage
Started 4 months agoLasted about 3 hours

Affected

Phone System

Degraded performance from 9:25 AM to 12:08 PM

Server 1 | Remote Apps

Major outage from 9:25 AM to 10:12 AM, Degraded performance from 10:12 AM to 12:08 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We believe a fix has been implemented and are currently monitoring the result.

  • Identified
    Identified

    We are continuing to work on a fix for this incident. Due to a power supply fault in the local area we are currently unable to supply website hosting or answer phone calls due to no power at our office. We expect this issue to be resolved within 1 to 2 hours.