EB IT Support LTD - Dashboard is down – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
Dashboard is down
Resolved
Major outage
Started 9 days ago
Lasted 3 minutes
Affected
Dashboard
Operational from 12:12 PM to 12:12 PM, Major outage from 12:12 PM to 12:16 PM
Updates
Resolved
27 May, 2025 at 12:16 PM
Resolved
27 May, 2025 at 12:16 PM
Dashboard is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
27 May, 2025 at 12:12 PM
Investigating
27 May, 2025 at 12:12 PM
Dashboard is down at the moment. This incident was automatically created by Instatus monitoring.