EB IT Support LTD - Dashboard is back up – Incident details
Report an issue
Dashboard
Get updates
Email
Slack
Discord
Report an issue
Dashboard
Get updates
Dark mode
All systems operational
Dashboard is back up
Resolved
Major outage
Started 8 days ago
Lasted about 1 hour
Affected
Dashboard
Operational from 10:29 AM to 10:29 AM, Major outage from 10:29 AM to 11:45 AM
Updates
Resolved
10 April, 2026 at 11:45 AM
Resolved
10 April, 2026 at 11:45 AM
Dashboard is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
10 April, 2026 at 10:29 AM
Investigating
10 April, 2026 at 10:29 AM
Dashboard is down at the moment. This incident was automatically created by Instatus monitoring.