EB IT Support LTD - Server 2 | Website Hosting is back up – Incident details
Report an issue
Dashboard
Get updates
Email
Slack
Discord
Report an issue
Dashboard
Get updates
Dark mode
All systems operational
Server 2 | Website Hosting is back up
Resolved
Major outage
Started 29 days ago
Lasted 19 minutes
Affected
Server 2 | Services
Updates
Resolved
20 March, 2026 at 4:32 PM
Resolved
20 March, 2026 at 4:32 PM
Server 2 | Services is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
20 March, 2026 at 4:13 PM
Investigating
20 March, 2026 at 4:13 PM
Server 2 | Services is down at the moment. This incident was automatically created by Instatus monitoring.